Función SI anidada en Excel

Comparte en tu red social favorita...

Ejemplo fácil de Función lógica SI.

Microsoft Excel cuenta con la posibilidad de hacer una Función SI anidada en Excel con la función SI, y podrás usar la Función SI con varias condiciones en el programa.

En este post hablamos de la función Excel SI anidada te ayuda a ser más preciso en tus evaluaciones y verás un ejercicio de Excel con la función.

Como sabes existen varias funciones lógicas en el programa de hojas de cálculo Excel. Entre ellas seguramente que conoces la función lógica SI.

En Excel las encuentras dentro de la categoría de funciones lógicas.

Puedes practicar ejercicios en: Excel función SI.

Con estas funciones lo que haces es evaluar una condición para obtener un resultado lógico.

Dicho resultado puede ser verdadero o puede ser falso.

Como te decía, la más conocida es la función SI, puedes leer sobre ella en mi artículo:

Descubre las funciones de información y las funciones lógicas de mi otra web hojas de cálculo About.com.

En una hoja Excel tienes las notas de unos alumnos, quieres saber si el resultado de cada alumno es aprobado o suspendido.

Con la función lógica SI, puedes escribir una fórmula tal que si la nota es menor de 5 te devuelva el valor Suspenso, y en caso contrario Aprobado.

Esta es la sintaxis general de la función:

=SI(condición lógica; “Valor verdadero”; “Valor falso”)

Esta la que refleja el ejemplo:

=SI(A6< 5;» Suspenso «;» Aprobado «)

En este post vas a ir más allá y te voy a explicar la función lógica SI anidada.

Como ya sabes la función SI te permite que al hacer una pregunta puedes establecer dos posibles respuestas.

Pero hay ocasiones en que existen más de dos respuestas posibles, en estos casos tienes que volver a usar la función SI en uno de los parámetros de una función SI inicial.

Esto puede ser tanto en el argumento verdadero como en el argumento falso.

Un ejemplo de Función SI anidada en Excel:

Imagina que trabajas como contable en una empresa y desde el programa de contabilidad  has creado un listado de clientes que  tienen   o no saldo.

En la empresa se ha decidido llamar a aquellos clientes que nos deban una cantidad   inferior a 3000 €.

Y por otro lado se ha decidido enviar un Burofax a aquellos que nos deben una cantidad superior a esa cifra, con ello queremos dejar constancia de la reclamación de la deuda.

Ten en cuenta que el programa de contabilidad que suministra también aquellas clientes cuyo saldo es cero.

Esta imagen refleja la situación:

                                                                    Funcion logica SI anidada

Primeramente se te ocurriría usan una función SI normal.

Donde los argumentos podrían ser algo similar a la siguiente expresión: (Las celdas dependen de donde tengas tú los datos de los saldos).

=SI(H2>=3000;»ENVIAR BUROFAX»; “LLAMAR”)

Pero no es correcto porque qué pasa con los clientes cuyo saldo es cero? Es aquí cuando entra en acción usar una función SI anidada.

En concreto sería esta:

=SI(H2>=3000;»ENVIAR BUROFAX»;SI(H2>0;» LLAMAR «;»NADA»))

De esta manera, estás indicando con la Función SI anidada en Excel que en el caso de que el saldo del cliente en cuestión sea inferior a 3000 euros, hay dos opciones:

La primera: sea mayor que cero con lo cual se mantiene la opción llamar.

O la segunda: que el saldo sea 0 en cuyo caso no hay que realizar ninguna acción.

Con ello has introducido un tercer parámetro que con la función lógica SI sin anidar no hubieses podido tener en cuenta.

Conclusiones sobre la Función lógica SI anidada en Excel:

La posibilidad de crear una  Función SI anidada en Excel y así poder anidar funciones es bastante grande, más o menos se permiten hasta 65 anidaciones, lo que no está nada mal.

Existen otros muchos casos en donde poder usar la Función lógica SI anidada en Excel, si tienes algún ejemplo te animo a que no lo dudes y escribe sobre el mimo en el apartado Comentarios al pie de la página.

Igualmente si necesitas contactarme directamente puedes mandarme un correo electrónico al emailhola@excelcontabilidadytic.com

Para finalizar este post sobre la Función SI anidada en Excel accede a las redes sociales y hazte seguidor de Excel, contabilidad y TIC, estarás permanentemente actualizado sobre todas las novedades de esta web.

 FACEBOOK – TWITTER – LINKEDIN.

Temas Excel relacionados que te interesa conocer:

Si necesitas mejor un texto te recomiendo el libro: Excel 2013. Domine Las Funciones Avanzadas De La Hoja De Cálculo De Microsoft.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.